Need Help With Tasker "Select Renderer" Command

Issue description:
I’m trying to understand what needs to be put in 1 or any of these 3 fields to change the Casting Device (Rendered) to the local device. My goal is that Tasker sets everything so while I am away from home it is ready to Render videos that have been synced to the device on the device. Want to make it as automated as possible with as little clicks for me :slight_smile:

I’ve used the documentation found HERE specifically the intent for Change current renderer (Unlocker), however when I put in the Renderer type as an INT equal to 2 Tasker doesn’t like leaving the others blank.

When I’ve tried putting INT equal to 1 OR putting STRING equal to “Local device” in the Renderer param nothing seems to happen, 1 being the number of the “Local Device” in my “Manage Host” section. This might be a misunderstanding on my part for the “IDENTIFIER” [String]: The identifier of the target renderer in the document I found

As for the middle param “Migrate any active media and playlist” I’m not sure if this is an INT / BOOL / STRING or if it is [Required] or not, the documentation doesn’t really say anything about that one, maybe something new since it was written?

I could be looking at something entirely wrong, unfortunately wasn’t able to find too much detail other than the INTENT section to help me out, could just be as simple as pointing me in the right direction for the specific Tasker Command section.

Logs: (Join files do not paste the content of the files here !)


Additional information:
As always love the heck out of the app (for years) this is my next step in trying to kill off some of my Plex stuff and move to Kodi only.

As a starter you read the wrong help page :slight_smile:

Yatse Tasker Plugin is the page about the Tasker plugin.

Not sure what you mean by tasker does not like you can leave them empty.

1 Like

Ha, see I knew it, thanks for the re-direct :smiley:

So here is what I’ve tried:

Renderer param: NULL
Migrate any active media and playlist: NULL
Renderer type: 2

But when only applying a value for Renderer type and hitting Ok in Tasker I get a popup error message, did I miss input this?

Then as the template says : How to get debug information and open a proper issue :wink:

Sorry sorry, just figured it out

Renderer param

  • This is the String parameter in documentation

Renderer type

  • This is the Int parameter in documentation

Looks like Tasker wanted it this way and is now happily doing what I was expecting. Certainly don’t want to criticize the work you’ve done, especially on documentation (I know how big of a pain that is). But maybe an example or so would help in that space, or a reference to the names in Tasker?

Example to Changer Render to Local Device (no media migration):

Renderer param : Local Device
Migrate any active media and playlist : NULL
Renderer type : 2