Music playback not working on LS50 Wireless speakers

Issue description:
As per subject, I cannot play music from my Plex Server to a pair LS50 Wireless dlna-enabled speakers.
I am able to see the speakers in the list of players ([email protected]) and to select it but no music is played. When I switch player to my Google Home Mini music streaming works perfectly.

I was hoping to use Plex Server + Yatse to replace the dedicated DLNA server + HiFi Cast DLNA player app (with which streaming to the LS50 Wireless works nicely).

Logs: debug 2.log (434.3 KB)

Nice artist but strange genres affected to it :stuck_out_tongue:

The error returned by your receiver is not clear at all :frowning:

Can you try to check or uncheck the alternative dlna flags option in settings ?

The other probable cause is Plex certificate that is let’s encrypt and they dropped legacy support so if there’s no recent firmware for your device you may need to connect to Plex without https.

Remove the host, do not enter the plex.tv account, press skip then manually add the those with the lan IP. Then in the settings verify that it’s http and not https and of course be sure that your Plex server allows connection without https.

I literally wrote a reply saying ‘It’s working! etc etc’ but there’s some weird stuff happening…

First of all, I was indeed running an older firmware on the speakers, after updating it I can play music … which ofc means a lot of Dead Can Dance :sweat_smile:

However, here comes the weird part… it looked fine at the beginning, it played music. Then I stopped it and try to play it again ('Nierika’ track), no music.

So I stopped the casting on Yatse, opened HiFi Cast app, and try to stream ‘Host of the Seraphim’ track from MiniDLNA server… it worked, so I stopped and killed the HFC app for good measure…

I returned to Yatse, started to stream again ‘Nierika’ … music comes from the speakers, but it’s ‘Host of the Seraphim’??? I try to skip track, the music stops for a second… and again ‘Host of the Seraphim’ starts :dizzy_face:
Even the track progression slider works, play/pause commands work, etc but it keeps on playing the same song… skipping just restarts the song…

At the beginning I thought the MiniDLNA server was interfering somehow so I turned it off… so that Plex’s own internal DLNA server would be up and running.
That solved nothing.

KEF’s own streaming app sees Plex’s DLNA server and is able to succesfully initiate streaming of a given album, but when I switch to Yatse, it seems it is unable to pick the correct track and is only able to communicate simple play / pause commands to the player

Attaching new logs here. If you need Plex DLNA server logs I can upload those as well. debug 5.log (545.8 KB)

EDIT: the logs are from subsequent trial, so the track titles are different from what I wrote above. Anyway, same result

Yatse does not use the UPnP part of Plex it directly use the http API.

Anyway same error:

<errorCode>600</errorCode>
<errorDescription>Invalid Args Value</errorDescription>

It’s a vendor specific error without much details :frowning:

Have you tried to alternative dlna flag option I mentioned earlier ?
Can you still try in http mode with local IP as requested too?

And just in case the library I use does not encode some strings, can you try a song with a genre that have no / or , (So a song with only 1 simple genre)

Other possibility would be that I send too much data and the receiver does not support them, but I don’t know how to identify that.
Can you try the app bubbleupnp that probably works too and provide logs when it play stuff ? (It generate logs I can read)

I suppose you gave up :slight_smile: