Music on local device - albums "scattered"

Hello,

when switching to play music from local device, the Albums there appear to be “scattered” and showing as multiple albums. It seems to be related to special characters, such as “Vašo Patejdl”.

The same album from the local NAS shows OK.

Tried to re-tag the album to avoid possible differences in album artist, but still not working. If I want to play the whole album, I either have to list it via “local files” or make a multiple selection…

Thx in advance for help.

As the template says please provide logs and details about source of the files? Downloaded from Yatse?

Sorry, I got too fast.

Generated a log and sent it via E-mail. However not sure, what it will say, as I could only refresh the library to “reproduce the problem”. But the problem is somehow “static”, so not sure, if the library refresh will be able to reproduce it.

Thanks

You did not answer the question about where the data is from :slight_smile:

Logs shows that your Android returns multiple albums

2019-09-08 22:19:15.963 Verbose/LocalDeviceDataProvider: [email protected]: Insert Audio Album: Benefice ト稿rnテスch konテュ
2019-09-08 22:19:15.979 Verbose/LocalDeviceDataProvider: [email protected]: Insert Audio Album: Benefice ÄŤernĂ˝ch konĂ­
2019-09-08 22:19:15.993 Verbose/LocalDeviceDataProvider: [email protected]: Insert Audio Album: Benefice černých koní
2019-09-08 22:19:16.007 Verbose/LocalDeviceDataProvider: [email protected]: Insert Audio Album: Benefice 膷ern媒ch kon铆
2019-09-08 22:19:16.021 Verbose/LocalDeviceDataProvider: [email protected]: Insert Audio Album: Benefice černých koní

So it looks like your music data is corrupted.

Well, I don’t fully understand the question. The music data are local MP3 files. Copied over from my NAS server, where the same files play just fine.

You found it just right - that’s the same album, but showing also under different names.

I use MP3Tag to name the tags in MP3, and the problem really shows only at local device.

Any recommendation, how to correct it?

Seems there’s wrong data in the mp3, I’m pretty sure most other audio players will show the same.

You probably want to fix all the mp3 then clear Android database: https://www.doubletwist.com/help/question/how-do-i-reset-the-android-media-scan-database/

Again - it is not (!) - the same files played from the NAS via local network are showing as OK :frowning:

Then do not believe me :slight_smile:

Yatse display the data that is inside your Android device database, as the logs show for your Android this is different albums, so Yatse displays it as different albums.

Use another player and most will display exactly the same thing.

Yatse does not touch or read the tags or the content of the files, it just display what Android gives.

Well, definitely I want to believe You, and especially I want it to get working, so we’re both on the same side (I hope) :slight_smile:

One new thing learned - there’s something like Android device database, and Yatse is reading that, not directly the MP3 tags. I did not know that, so I can start looking in that direction.

As for other players - tired Media Player Classic, and it strangely shows only a fragment of all albums. None of them with the East Europe codepage. After a little playing around with that (including manually my SD card\Music directory) it loaded also the other albums - see the screenshots.

Here it really shows the albums correctly. But maybe the MPC is not (?!?) reading the Android database, but the Tags directly…


I did told you how to reset the Android database if it had bad data in it :slight_smile:

Have you tested that and forced sync in Yatse? All I know is that there’s nothing I can on Yatse side if your device send wrong data Yatse will display wrong data.

Thanks for Your support.
I did reset the database, the outcome was same/similar. So problem still not solved, but at least new things learned.

Regards and thanks.

Well not much more I can do :frowning: You can still use file mode to play whole albums from there.