Make jsonrpc Port (9090 by default) configurable for kodi on FireTV Stick 4k

Hi!

After installing kodi 18.9 on my FireTV Stick 4k it wasn’t possible to activate remote control settings (i.e. webserver and “allow remote control from applications on other systems”).

On every kodi startup it showed a message “remote communication server failed to start” and I tried changing the weberver-port to “10080” (in the kodi UI) and the event-server port to “10777” (in “guisettings.xml”).

After changing these values in Yatse it was able to control kodi again but it still shows the Host as “offline”.

The communication server message on kodi startup still appeared on every startup and meanwhile I found out, that this was caused by the fact that kodi uses port 9090 for jsonrpc by default.

After Changing the jsonrpc port to “10090” in “advancedsettings.xml” the startup message never showed up again but Yatse still shows the host as offline.

Would it be possible to make the jsonrpc port configurable in Yatse to get it working again?

Thanx in advance!

cu
Lanzi

You are mixing things, that part is for event server / TCP server and Yatse works without it.

You need to enter the http port 8080 by default.

As the Wiki explains Kodi also often display a wrong IP address ik it’s settings and you need to get the real one.

I didn’t read the IP from Kodi but assigned it as a reservation for the Fire TV Stick in my DHCP server - it’s the correct one. :wink:

The http port 10080 and also the event server port 10777 are open and reachable.

If this behaviour of Yatse isn’t related to jsonrpc why doesn’t Yatse show my Kodi instance online?

Because you have an other issue not related at all to port 9090.

Provide logs How to get debug information and open a proper issue so I can know more.

Here are the logs for the Kodi standard-config (webserver-port: 8080, event-server-port: 9777, jsonrpc-port: 9090) after Fire TV Stick had just rebooted.

debug-20211005_015857.zip (1.6 KB)
kodi.log (108.0 KB)

System behaviour:

Kodi is starting with error-message “remote communication server failed to start” and it’s not possible to start webserver (message “… failed to start”).

Trying to enable the option “allow remote control from applications on other systems” causes another message “… failed to start” and let’s Kodi crash.

After Kodi-crashing the Fire TV Remote App for Android needs a very long time to connect to the Stick.

Yatse does not connect to Kodi.

Further logs with my customized config will follow.

Here are the logs for the customized Kodi config (webserver-port: 10080, event-server-port: 10777, jsonrpc-port: 10090) after Fire TV Stick had just rebooted.

debug-20211005_022618.zip (5.4 KB)
kodi.log (149.7 KB)

System behaviour:

Kodi is starting with no error-message and the webserver can be started without any error.

Enabling the option “allow remote control from applications on other systems” does not cause any error message.

It’s possible to control Kodi with Yatse but not all features are working.

Yatse shows the host as “offline” and i.e. no information to a running media will be displayed in Yatse.

The Fire TV Remote App for Android connects to the Stick instantly.

You have configured Yatse to use SSL but Kodi is not configured to use SSL to obviously can’t work :slight_smile:

Properly configure Kodi SSL part or properly configure Yatse to not use SSL in your host settings.

Damned, you’re right … :stuck_out_tongue:

Thanx! :slight_smile: