Lost UPnP with samsung TV

kodi
#1

Hello,
Just sent an email with logs --> Yatse logs - 20190316_115839
debug-20190316_115839.zip (20.0 KB)

I received your message by miracle on play. :slight_smile:

Until today everything was ok, but now I lost playing on my Samsung smart TV. Yatse tries to connect to TV, but after few seconds comes back, but no play on TV. From kodi I’m able to stream to TV. From TV able to play kodi media.

---- Technical details, please do not remove ----
Yatse: 9.0.0-11006 [true/0/68/126]
Android: 9 - 28 [arm64-v8a,armeabi-v7a,armeabi]
Device: samsung - SM-G965F [star2ltexx - star2lte]

0 Likes

#2

I just recognized I have a new version 9.0 (release on 2019-03-15), is it possible this causes the issue ?
Can I try to downgrade and test this version causes to lost streaming to my TV?

0 Likes

#3

Nothing have changed about UPnP since a long time.

What do you mean by after a few seconds comes back?

Have you tried to reboot your Wifi router in case it does upnp proxy and your TV?

0 Likes

#4

Come back means,
No report on success or not
No report what is the actual tenderer

Also I read log as well and some errors shown by id of render destination.

Chech in my log
Nappali
As text
You’ll understand why it drops the TV

0 Likes

#5

No you read wrongly the logs :slight_smile:

The errors are about your RT-AC66U that does UPnP proxying. That why I asked if you had tried to reboot it and rebooted your TV.

This really looks like a network issue. Can you make a video about no report of what is the renderer, it always shows the renderer even before even trying to connect it so I’m lost about that part of the issue too.

0 Likes

#6

I rebooted both, also a copper 1G network switch as well, sure phone too.
No changes.
Actually I used a VPN for some reason, now it is deactivated.

Please let’s try, give me the previous release link to downgrade on phone just for double check.

Also I’m agree with you it is something regarding network, but no any changes in past few weeks. :frowning:
No firewall changes, no VPN changes, no equipment changes, no changes on ISP connection, also DHCP is still the same in past half year, no DNS server changes, protocols are still same, and no firmware upgrade on router.

Only change is new version of yatse on yesterday.

0 Likes

#7

About renderer:

I’m able to start any media on kodi
I’m able to start any media on phone

Only media playing redirection to my TV not working anymore.
All other things / settings / read / config / watch still working like before.

0 Likes

#8

You can find APK on Apk mirror and I did ask you a video about what you describe please.

0 Likes

#9

OK man!

I’ll do some video of screen on my phone tomorrow.
Sure I’l switch back to English before :slight_smile:
Then I’ll try to downgrade for double check.

What was crazy in log an IP which is doesn’t / couldn’t exist on my network:
coz I’m on 10.0.0.0 and 255.255.255.0 therefore 192.168… doesn’t exists and will never exists on my network!
2019-03-16 11:49:55.054 Verbose/ga: [qa,5,main] Invalid segment packet received:/192.168.168.168 /10.0.0.153/24 [/10.0.0.255]
2019-03-16 11:49:59.238 Error/ConnectionManager: [email protected]: Renderer selection timeout. Reverting to default renderer

0 Likes

#10

Ok another user did provide better repro case and details.

Version 9.0.0a is pushed to Play Store to fix this. Can take a few hours before reaching your device and being accepted by Google.

2 Likes

#11

Awesome. Loaded from apkmirror and also fixed streaming to LG-TV. Thank you

0 Likes

#12

I can’t believe!
What was the issue?
9…a resolved the issue !
I feel that initially coz no other cahnges.
Anyway everything is back!
So great job !
Thanks!

0 Likes

#13

SO
Media redirection is back

BUT

Like at the start of my purchase we’re back

  • No possibilities to forward/reverse media from yatse
  • lost all control on TV via remote controller (original)
  • from TV any button on RC forward/reverse/stop/pause/fast forward etc will stop playing media

You have to give back to us all controls like before.

Actually (9…a) this is only a partially working media redirector.
Sorry
This is the truth.

I lost my thrust, please give back all my possibilities like was before 15th of march '19

TY

0 Likes

#14

I have no idea what you are talking about.

  1. forward / reverse where never possible with UPnP
  2. When connected to an UPnP device there’s nothing to control it’s like that since about 2 years.
  3. What happens on your TV once the stream is started is 100% independent from Yatse.

So open news issues with details for each and showing me that any previous version did behave differently …

0 Likes

#15

Its a bit crazy
what was before 15th of March
1 - correct fast search on renderer’s on LAN
2 - redirect
3 - play
4 - move to any point of time in media
5 - pause if call
6 - continue if call stopped
7 - all possibilities still working on TV’s remote controllers

What is actually working?
start and stop

0 Likes

#16

Last time:

Open new issues for issues with proper logs / descriptions and proving behaviour before 9.0.0.

Nothing have changed in that regards in 9.0 and the small typo for UPnP host connection is fixed.

0 Likes

#17

Man

It is not a new issue!
I need back all my things why I purchased a pro of your great app.

I lost all.
I don’t need a simple redirector, I have as free.
I need a redirector, media controller, forward/back/pause/start etc

It was all in Yatse before, this was the reason why I purchased your app!

Pls give me back my controls, like was before.

It is not related to version up on android ?

0 Likes

#18

Are you serious? Is it so hard to read what I write?

Open damn new issues with asked details and logs!!!

For the LAST TIME: NOTHING HAVE CHANGED I CAN’T GIVE BACK SOMETHING THAT IS NOT MISSING AND WAS NOT REMOVED …

0 Likes

#19

I’m serious

Before
I was able to move to any time in media.
YES it was and worked (ugly and cumbersome but worked)
I was have all the controls on TV remote while playing from kodi (actually all grey-ed out)

0 Likes

#20

Good news.
Everything is back!

you mentioned

  1. forward / reverse where never possible with UPnP
  2. When connected to an UPnP device there’s nothing to control it’s like that since about 2 years.
  3. What happens on your TV once the stream is started is 100% independent from Yatse.

But
Two things on expert settings, will solve the FW / RW
Also TV remote is back, so I have a control via Yatse or IR, both is ok.

0 Likes