Kodi on Nvidia Shield TV not seen by Yatse


#1

Hi! Just got a Nvidia Shield TV and first thing I did was to install Kodi. When I use Yatse wizard to detect it, it finds nothing. I’ve been searching for hours for how to do it, to no avail. So, I decided to post here hoping to get some help.

Allow remote control via HTTP is on
Allow remote control from applications on this system is on
Allow remote control from applications on other systems is on
UNnP/DLNA: Everything is on
Airplay is on

Thanks!


#2

You do not give logs or Kodi version :slight_smile:

If you are using Kodi 17 this is normal they broke this function and you can configure manually all is explained in the connection wizard and in the documentation.


#3

I have 17.6. I read most of the Wiki and the documentation available here and tried to configure manually, 192.XXX.X.XXX with port 8080 (and others). Still can’t find the device.


#4

Manual configuration is not about finding the device it’s about connecting to it so you already know it’s IP and port.

I suppose it gives you an error (Well no I know it does :p) so why not provide the asked logs?


#5

Sorry about the log! Here it is!

debug-20181220_191234.zip (3.9 KB)


#6

failed to connect to /192.168.0.108 (port 8080) from /192.168.0.101 (port 35960) after 5000ms

There’s nothing listening at that IP and port triple check your Kodi settings and IP.
If you use DHCP IP have probably changed. You should try SPMC or Kodi 18 that have working zeroconf for autodetection.


#7

Hi I also use Kodi on Nvidia shield TV. I think you have to look up the correct ip adress to your shield TV. It’s not the IP address listed under system in Kodi you should use, it’s the IP address listed under the main network system tab on the shield TV you should use. And remember to change the port number to something unique that doesn’t interfere with any other services on your network.


#8

Still not working! Oh well! It’s OK! I’ll use the Shield remote but I’ll miss Yatse.

At least it’s working great on my Pi (same network). So my guess is that it’s something I’m missing on the Shield side.

Thanks for the help!


#9

Change port, use SPMC.

I use Kodi on shield daily :wink:


#10

Yeah! I tried changing ports and i tried SPMC as well, same results. I’m missing something, probably something stupid too.


#11

… and it was something stupid. Ports 8083 and 9777 were not forwarded on my router. I was sure they were.

Also, and I don’t know why, I have to close Wifi on my phone and restart it, sometimes.

Anyway, everything is working perfectly now.

Thanks for the helps guys!