Kill Screensaver when playing content

So I’ve noticed that Kodi won’t exit its screensaver when starting to play a movie from Yatse, so unless there isn’t a setting I missed (in Kodi or Yatse) I suggest when initiating content playback, Yatse could just call the Kodi gui for it to exit its screensaver before executing the playback request.

And sorry if I missed something and are yet again asking for a redundant feature. :stuck_out_tongue_winking_eye:

This is a known Kodi bug that is known for a very very long time and was reported a few times :slight_smile:

This is a 2 lines changes on Kodi side to fix but I’m banned from there for trying to help Kodi users :slight_smile:

You can try to report to them one more time :slight_smile:

The lines:

Should actually be placed just before here:

Once done the issue will be fixed by magic.

And I’ve decided to not workaround it like the hundreds of other workarounds I have because there’s no magic command to dismiss screensaver and only do that in all cases. So sending random commands could have side effects.

Doesn’t surprise me at all, that being a bug, though I’m surprised you opted against the Yatse side solution - I mean, just adding something like “arrow up” as Yatse requests the playback should be very unlikely to cause any issues, right? But it’s your call, of course.

And I’m former Team Leader for the Swedish Ubuntu LoCo and also been involved in some other open source related projects, so no need to further explain the utter dysfunctionality that is the norm in open source related project management, I’m well aware… Some 10 years ago it took me and a couple of pals 3 weeks of banter in their forums to shame the Blender Foundation devs into implementing a pop-up request to save the current scene when exiting the app. They argued you had only yourself to blame if you mistakenly excited the app without saving your file… :joy:

Kodi is a very special case :slight_smile: Never seen anything like that, some useless people that think because they are in the foundation should place their need and pride over users and logic even if they are unable to achieve anything :slight_smile:

And sorry but yes sending arrow up as many side effects if no screensaver is shown :slight_smile:

  1. It can make an unpleasant beep
  2. It actually moves up so can select something else, trigger an addon or change a value in a selector

Your description of the Kodi devs sounds like normal FOSS development to me… :joy:

And I hear you - man, stuff like this is so annoying. It’s one thing if it’s a hard problem to solve, but if it’s as simple as your previous post suggests, it’s just ridiculous… :roll_eyes:

Beyond that I now got more into the Yatse workflow with Kodi, and you’ve done a truly amazing job here. Much appreciated.

It is as simple :slight_smile: Try to report you can reproduce from curl so no need to talk about Yatse and some of the most stupid guys are far away now :slight_smile: But I’m still banned so can’t do a simple PR.

Because FOSS is all about banning from github the guy who did more for Kodi than 50% of the “Team” :wink:

So you’re not tempted to fork Kodi? You seem like the perfect lead for such an undertaking - though of course a huge fukn commitment… :stuck_out_tongue_winking_eye:

This is way too vast and out of my comps :slight_smile:

While I could bring some organisation and fix many things to the API and some internals (like WTF: for 1 action you have 4 to 6 different ways to do the preparation for it depending on GUI/Python/JSON/EventServer and other edges cases … with all differences …) multiplatform cross compiling and the most important part the players are not something I know :frowning:

Kodi actually just need some lead like it used to be a long time ago, now it’s randomness and the one who shout the most that wins decisions :stuck_out_tongue:

Hmm, just a question - what if you added an arrow up after the playback request? That only seem to show the playback controls - which you get automatically when starting playback anyway…

Well, you probably thought of that as well and have a good reason why not too, haha - so I guess the only way is yo disable the Kodi screensaver… :stuck_out_tongue_winking_eye:

This is a big skip / chapter skip depending on the Kodi version / media type and loading speed on Kodi side :wink:

And no the proper way is to report to them so they fix :slight_smile: Or you can even make the PR yourself and explain what it fix, I’m sure it can be easily merged if you do not name Yatse. It’s actually just moving 2 lines a little up to cover playing media without a playlist. (And no using playlist all the times have other bugs on Kodi so it not a proper workaround either :p)

Of course that’s the proper way, haha, but due to my history with it I’m not gonna get involved in any FOSS development/forum stuff again, I’ve learned how unhealthy that is… :stuck_out_tongue_winking_eye:

But yeah, I disabled the screensaver now… :joy: