Keep offline media available during library sync

I have the same library for both kodi and Jellyfin, but for now it’s jellyfin that I download offline media from. On a good connection it usually takes about 3-5 minutes for a yatse library sync to complete, and it seems to be about the same for both backends.

Sometimes during sync the TV shows library in the app disappears (shows “no media”, or just show a few of the series in the tv-shows category), but it comes back when the sync is complete. When on a good connection this can be a mild annoyance to not be able to watch anything for a few minutes. What’s worse is that during this time I can’t start any of the offline media files I’ve previously downloaded (as the library looks empty). The files are still there; they do not need to be re-downloaded after sync, but they cannot be accessed.

The big problem is when yatse decides to do a sync when I have a bad coverage or otherwise unreliable connection. This can make my offline files unavailable until the connection improves and the sync completes. For me this can occasionally be hours away.

I suppose disabling automatic sync would “solve” this particular problem at the cost of everyday convenience, but I really would like the the library to be fully available during syncs, or at the very least be able to access already downloaded media.

Please provide logs when it happens as the library is fully available during sync normally.

Details and logs sent in PM, but for the public record:

The problem is most noticable when I have a bad connection, but I managed to reproduce it (somewhat) by disabling wifi while sync was ongoing, and then reenable wifi again. Not all tv shows was unavailable after this, but at least most of those that had unwatched episode was missing.

The procedure was:

  1. Enable debug log
  2. make sure yatse syncs
  3. check that library is still usable
  4. disable wifi while sync was ongoing
  5. check that library now is missing some series
  6. enable wifi again
  7. start a new sync and let it finish
  8. disable debug log

Ok so yes there’s something wrong, the sync is failed, but strangely the backend says it’s correctly finished, leading to this situation.

I’ll try to reproduce the same error and fix.

Ok so found the issue there’s a specific case where errors are ignored, you are really unlucky if it happens often to you.

Anyway will be fixed for next release.

1 Like