Jellyfin TV Shows do not show up if non English metadata

Issue description:
Most of the metadata for my series in Jellyfin are in English and they show up without any troubles. For some series I have switched them to the German metadata and they don’t show up under “TV shows”. I even switched a show that was displayed from English to German and with that change it disappeared.
If I go to the Files section they appear fine.

Well without the mandatory logs not much I can tell :slight_smile:

Support issues have a template that require to be filled correctly.

Sorry about that

debug-20190807_090535.zip (181.9 KB)

Looking at the log it first looks good

2019-08-07 09:04:46.182 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Game of Thrones
2019-08-07 09:04:46.186 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Die Sendung mit dem Elefanten
2019-08-07 09:04:46.186 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Meine Freundin Conni
2019-08-07 09:04:46.187 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Die Biene Maja (2013)
2019-08-07 09:04:46.187 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: PAW Patrol
2019-08-07 09:04:46.188 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Der kleine Drache Kokosnuss
2019-08-07 09:04:46.189 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Nils Holgersson (2017)
2019-08-07 09:04:46.189 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Dark
2019-08-07 09:04:46.190 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Mama Fuchs und Papa Dachs
2019-08-07 09:04:46.191 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Savage Builds
2019-08-07 09:04:46.192 Verbose/EmbyDataProvider: [email protected]: Insert TvShow: Yakari
2019-08-07 09:04:46.192 Verbose/EmbyDataProvider: [email protected]: End Insert Shows: 11 [0.13s]

but then only the following series actually show up

Game of Thrones
Dark
Savage Builds

Ok so this is a bug on Jellyfin side. The shows after the language change report that they have 0 episodes.

Can you uncheck the option do not sync empty tv shows and force sync and see what happens.
The shows will be visible but depending on the issue level either the shows will really have no episodes or they will have.

That helps, with the option disabled they show up and look good (episodes show up and can be played). Thanks a lot.

Well there’s still an issue in Jellyfin that should be solved :slight_smile:

This is just a workaround. Can you report to them on their issue tracker? https://github.com/jellyfin/jellyfin/issues they will ask things and logs that I can’t provide and probably can’t repro your issue too.