Issues with app not being owned? (App Not Owned error)

I live in China and have to use VPN to access Google Play. I installed the application and purchased the unlock (actually re-purchased, as I also seem to have the legacy ulocker).

I am able to use Emby, etc, but after a while it shows the application is expired and I do not own it? I get the option to Quit or see more details. When more details is offered, I get the option to ‘Own’ the application from Amazon’s Appstore? But I do not!?? I am not even possible to do so, as the application is georestricted to my location (either China or the Netherlands?).

Anyway, I am NOT able to use the application as before and not sure how I should proceed. I can NOT use the VPN when I try to access resources, and I can not get it on Amazon.

Also, I tried the legacy unlocker (as I owned it) but this also doesn’t make a difference.

This is because of your phone that have stupid other app store that replace your normal Play Store Yatse app with a very old Amazon version.

You need to find the app that does that, tell me the name so I can yell at them, disable update from that app. Then install again the Google APK.

I noticed this yeah… but it happens without notifications. it is on an Oppo device and it showed an older version-Amazon in the changelog. How best to go about this?

Note: this doesn’t happen on other devices, like Lenovo or Samsung.

You need to find the store that does that and disable updates in it. Seems the default one on OPPO is app market on those device check if yatse is in it (it should not).

I have no way to know / find who does that on your device you’ll need to figure out. I can only yell at the app maker once you find it.

It seems Oppo’s AppMarket is the culprit. I luckily allows you to flag and “Ignore Updates” for applications, but it seems to downgrade applications; from 9.5.5 to 7.6 something.

I’ve send them a mail to remove Yatse from their store but I do not have control :frowning:

Maybe you can totally disable the Oppo AppMarket

  1. Go to settings
  2. Go to apps settings
  3. Find that app
  4. Tap on it
  5. You will find the option to disable it…

I tried, but they do not allow you to do so. (No disable option)

they placed their own apps under “System Apps” -> “App Market” and from there also disabled the “Auto update over wifi”, etc. But unfortunately not much else to do.

I noticed they did the same to BubbleUpnp and other apps, like Firefox. It is not my primary device, but certainly now I am convinced it never will be.

@gbraad oppo ask me for a proof that Yatse is present on their app market.

This is insane but can you please provide me screenshots?