External subtitles are listed in yatse and not seen in VLC

Issue description:
I have Kodi on RPi. Some movies have only external subtitles in srt files. Kodi plays these correctly. However in Yatse when I go to such movie the subtitles are not listed as they are with embedded subs and also when starting the movie to play on the local device with VLC, the subtitles are not available. Looking at the logs I can see, that the subtitles are found, but still they are not even listed in Yatse. What can be the problem?

Logs: (Join files do not paste the content of the files here !)
debug-20220417_231207.zip (11.8 KB)

From the logs
Starting external video player with intent: Intent { act=android.intent.action.VIEW dat=… typ=video/* flg=0x1 cmp=org.videolan.vlc/.gui.video.VideoPlayerActivity (has extras) } - Bundle[{from_start=true, title=1. epizód, subtitles_location=http://REMOVED:[email protected]:8080/vfs/%2Fhome%2Fkatonag%2FMultimedia%2FSorozatok%2FShetland%2FShetland.S04.720p.HDTV.x264-MTB%2FShetland.S04E01.720p.HDTV.x264-MTB%2Fshetland.s04e01.720p.hdtv.x264-mtb.HUN.srt}]

Yatse correctly find the sub and correctly send it to VLC. This sounds like a VLC issue or the file not accessible on your Kodi due to sources issue.

You might want to try with Mx Player (And select Mx Player as player in the settings)

Thanks. I have checked with MX Player and it displays the subs, so this part of the problem is with VLC indeed. I wonder if external remote subtitles work in VLC at all. Do you have experience with this?

Independent of this the availability of subs is not shown in yatse. What can be the reason for this?

They worked with VLC, they either changed their API or have a bug that should be reported to them.
As shown Yatse does send the proper command with the proper path to the sub it’s VLC that ignore seems to ignore it.

For the subs, Yatse displays the data that Kodi sends, if Kodi says there’s no sub then it displays no subs.
At the cast time it does still try to list the folder content in case it find some but it can’t do that all the time for every media.