Downloaded Media Freeze with VLC

Be sure to read How to get debug information and open a proper issue to provide necessary logs and information.
Any issue without the logs can be automatically closed without further notice.

Issue description:
After playing downloaded media for less than ten minutes, vlc stops playing and freezes. I have to quite vlc and open the media again through yatse until it freezes again.

Logs: (Join files do not paste the content of the files here !)
archivetempdebug.log (91.3 KB)


Additional information:

Your phone does not respect Android standards and kills Yatse in the background.

See and find the settings for your phone to stop doing that.

Heyo, I turned off battery optimization on yatse and I still get the same issue. please let me know if there is any fix to this issue.

this only occurs on offline play.

Provide new logs, but not much I can do here the logs shows that your OS kill Yatse. So it can’t serve the file anymore.

Here, it seems to occur every minute now.
debug.log (44.3 KB)

I don’t see anything wrong in that one, just VLC returning. I’d need VLC logs to know what happens.

Can you try Mx Player?

Here are the vlc logs.

The problem is still there while using mx player
vlc_logcat_20230317_115706.log (24.7 KB)

Do you transcode the files when downloading?

The error is not documented so would need VLC help, seems it can be related to hardware decoder issues, maybe you can disable it to see.

No I downloaded the original media. I ran vlc on the smb of the server and it streams just fine. It seems the issue has to do with the local stream yatse creates.

Also I don’t know if this helps but after I close the player there is a notification saying streaming from yatse that doesn’t go away.

The notification is normal it’s the webserver that serve the file it goes away after 5 minutes without anyone reading anything from it.

Seems the issue is about those files over http server from Yatse.

Can you send me the exact file that triggers this?

I’m not sure what file your asking for.

But here’s something I found.

I start an offline stream through yatse.
I find a different yatse notification with media controls but It’s stuck on 0 seconds, I don’t know if this is important.
When vlc eventually stops playing, I click on the square stop button on the yatse notification.
The notification goes away and the media in vlc continues playing for a bit before it eventually pauses again.

Oh also if I pause the yatse notification it plays for 30 more seconds.

The yatse notification have no impact it’s just to be able to display something is playing in the app.

I’m asking for the actual files that you try to play. Since you say no transcoding, one of the file from the server.

My upload speed is pretty terrible it would take a full day to upload one of these files. But this happens with all of my library files with different resolutions and codecs.
Could metadata be helpful ?

Also Im not sure but I suspect the stream is being paused for some reason(since unpausing through the notification seems to momentarily do something). I don’t know how this works, but does yatse have a way to control the stream playing to vlc?

Also when I use the download to folder option vlc doesn’t have any trouble playing it.

I’ll try to replicate this with other file types and try to use Kodi to see if jellyfin is contributing to the issue.

Yatse have no control over VLC at all it just server the file via an http server due to Android security now.

Reading a file via HTTP and via file is different so VLC can act differently.

Usually the issue is that the OS kills Yatse as in your first logs. It seems your OS no more kills the app, but maybe it still pause it somehow. (But don’t think I ever saw that).