Deleted TV Shows not removed from Yatse


I don’t know if this is a Kodi or Yatse Issue. Last week I upgraded to Libreelec 9.0 with Kodi 18. Right after that I can’t seem to remove TV Shows from Yatse. Previously I just deleted them from my Share, cleaned the library in Kodi twice and then synced Yatse and they were gone. I did the same with a show a few days ago, however the show is still in Yatse, just empty without any episodes. Anyone have a clue if something changed with Kodi 18 and Yatse in this particular case? Thanks!

Uncheck the kodi option to hide empty show and delete them from Kodi :slight_smile:

Duplicate of a few :wink:

Yatse displays what Kodi send.

1 Like

Thanks, I think I got confused because it worked automatically before. Didn’t think about that option, worked perfectly!

I’m afraid that didn’t work for me.

The option is already unticked, and Kodi is not showing the show “Designated Survivor”, but it still appears in Yatse.

Logs? Opening your own issue? :slight_smile:

Yatse displays what Kodi sends it does not invent data as it just can’t do that.

You need to clean your Kodi library either in Kodi menu or by importing the custom commands in Yatse.

Then you can force sync at any time by swiping down in the shows list.
If the show is still here then it’s still somewhere in Kodi.

I ve run into this issue also several times.
Sometimes Kodi does not show deleted Movies but Kodi removes it also not correctly from database (after you ve deleted it and Kodi cleaned library). So Yatse or some addons still show the video.

If you have installed “Global Search” on your Kodi, try to search for this TV show or movie. If it can finds it, open context menu and delete/remove it from library. After a scan & clean of library (and also a new scan via Yatse), the video should not appear again.

After cleaning the library the problem was solved. I would have thought removing something via Kodi will also clear the library. And maybe it does and this time I manually removed the TV show from my NFS disk. Oh well, sorry for the noise everyone.