Custom command not completing with voice control


First thanks for such a good remote, I have used it for years on and off and purchased it many times under different email addresses! Voice control and new IFTTT limits brought me back to using it instead of the OmerTu/GoogleHomeKodi NodeJS way I was doing voice routines before.

I have Advanced Wake On Lan addon installed in Kodi which turns my tv on fine running the plugin in Kodi. In Yatse I created a custom command ‘RunScript(script.advanced.wol)’ which turns the tv on ok too when I press it in Yatse.

The problem is trying to run the custom command by voice.

I say hey google, launch wake on lan but the tv does not wake.

Other voice command using hey google, kodi stop/pause etc all work ok.

Eventserver test ok

Its a pain to get application logs off my phone to the computer to send so hoping I can get away with telling you that it says roughly:

FireBaseMessagingService: Message received [1], params = host 2, command= QueryText:Launch Wake on Lan:action :action.wol params : allrequiredparamsPresent: true : confidence 0.76


Time/Date Yatse manager: command sent to Yatse

Any ideas if I am missing something simple? I searched forums but came up blank.

You can’t start custom commands from voice commands.

Since you only give 1 line of logs I can’t really check all, but to start a plugin you need to use the plugin name and preferably start plugin XXX else in that case it tries to actually do WOL.

If you Kodi device is on linux you can also use scripts like Kodi Starter script for linux: Linux script to start Kodi from Yatse (NeoAcheron) to intercept the WOL command and do anything you want.

That would explain why it wouldn’t work then!

I have tried other voice commands to start it by addon name but not had any luck. I tried:

kodi start plugin Advanced wake on lan
kodi start addon Advanced Wake on lan
kodi start plugin script.advanced.wol
kodi start addon script.advanced.wol

As well as trying it by voice I also added the commands to a Google Home routine so I know the commands were received 100% correctly, I guess the same as a confidece as 1 on voice commands. Still made no difference.

Unfortunately I am using an Amlogic s922H box which did have android but I am booting CoreElec directly.

As I fallback I have a Linux server on the network which is used as a NAS among other things which I could install Kodi on along with the script you linked. The advanced Wake on Lan addon from the official Kodi repo has an option to send the WOL packet as Kodi boots, so running that script would also run the WOL addon, even if I dont have a screen attached to use the Kodi install there.

I would rather not include another box if I don’t have to though. I know im missing something simple as it works both by running the addon manually and by the custom command.

I’m not sure logs wil help you, at least from your Voice extension app. But if you want logs from there or from Kodi I will provide.

I needs assistant and Yatse logs.