CoreElec 9.2.4.1 partially working

Issue description:

Since the migration from CoreElec 9.2.3 to CoreELEC 9.2.4.1 recently (yesterday) on my Odroid C2, Yatse say that my device if offline despite I didn’t changed anything in my configuration and I didn’t updated Yatse. I use the Yatse version: 10.3.5/7110814-arm61-v8a with pro license.

I can:

  • use arrows and back button over HDMI CEC and all is working.
  • move on Kodi’s menus with Yatse
  • do restarts from Kodi menu
  • start playing channels from Kodi (same for files stored on a drive)

but
I cannot

  • do CEC activate or CEC deactivate to shutdown the TV
  • start playing channels from Yatse (same for files stored on a drive)

Logs:
Not sure if it is relevant here

Screenshots:

Additional information:
N/A

What could possibly makes you think logs are not relevant ?

Logs are mandatory. All I can say is either Kodi changed it’s config during update or corelec broke something.

Hi Tolriq,

Thanks for the quick update. I will try to provide the logs by EOD by following your tutorials.

Finally, I reverted to 9.2.3 version of CoreElec and all is working fine with Yatse.

You do realize that this does not solve anything and will just prevent you to update for ever as they won’t be able to fix what they broke? :slight_smile:

Yep I know (I’m a software/linux dev) :slight_smile:.

I wanted to have something functional for my main TV because else it is a pain to watch TV with my GF and she is complaining :blush:. I use Kodi and TV headend with an USB tuner on my Odroid C2 to get channels from an antenna on the roof + Yatse as a remote controler (we lost the main remote controler of the TV). We don’t have other options to see TV (I have a very poor wired connection <1 mps and no options from the provider to get TV channels from their box…).

I don’t have time to extract logs now, but I will do it when I will have (move to 9.2.4.1, extract logs and revert to 9.2.3).

My first intention was to create an issue on CoreElec’s github, but they blocked ability to open issues…

Thanks for your understanding

Hi,

Here are the logs:

I tested with latest CoreElec 9.2.4.2 on Odroid C2.

I did several request by using the up/down/left/right keys + back key. I move in menus and I tried a WOL because Yatse say that the device is offline so I cannot reboot/CEC activate.

Thanks

Webserver is not started on Kodi check your configuration :slight_smile: