Changing volume while yatse is active or in background makes a volume difference

Be sure to read to provide necessary logs and information.

Issue description:
If I have yatse open on screen and change volume it needs two presses and change by 2.5 on my receiver, if yatse is in background one press is enough and uses my selection of +/-1.
Logs: (7.5 KB)

Additional information:
Samsung android 10, newest Kodi Nightly, beta yatse, denon/marantz plugin.

I’m not sure to understand as your description is not really complete.

But I think what you want is to disable the option volume keys show volume dialog.

If I have yatse remote on my Samsung phone so i can control everything. Using the volume keys need two presses to change volume and by increments of 4 or something its random seemingly because if I go from 16 and one press up it might go to 20.5 if I press down fast after it might go to 15.5 or 14 instead of 16.

When I have yatse as a notification in background and press volume key up/down it changes by 1 as I have set in marantz plugin.
Sorry for bad explanation.

Seems disabling volume keys show volume dialog solved it as you said. Thank you :slight_smile:

Ok so this is normal the dialog is using a seekbar and not just +/- so there’s rounding and values are absolute (but 0->100 is not linear when converting to Db) so the plugin volume steps is not applied.