Cannot play video remotely from Emby

Issue description: I cannot play videos from my Emby server on a remote network using Yatse. Eveything appears to work except videos. I can view my library and play music but get an error regardless of the video player selected. Using MX player I get a “Cannot play link” error. I have remotely tested both the Emby Android app and a browser and both play video. Also, Emby is behind a Traefik reverse proxy. Thanks

Emby server:

Logs: debug.log (97.6 KB)

From the logs all worked correctly on Yatse side, try with VLC or an Mx player beta.

Then check your traefik logs for possible issues.

Thanks for the quick response.

Tried VLC, same error.

It seems that the get request for video a 401 unauthorized error is returned while music returns 200 and plays without issue. Also getting “Error HttpServer: Access token is invalid or expired.” in the Emby server logs. Any thoughts? Thanks

remote video.txt (4.5 KB)
remote audio.txt (5.5 KB)

Well Emby have probably changed / broken something I’ll try to repro with Emby 4.5 else I’ll maybe need a test account on your server to see if there’s some specific configuration somewhere.

Sure. No problem. I can setup a test account if you need one. Just let me know. Thanks

So yes can’t repro with will need a test account or first test with in case it was a temporary bug they already fixed :slight_smile: