Auto search & update host IP on launch

I read that Yatse should automatically try to connect to the Kodi host IP, even if it was changed by router, as long as the MAC address is the same.
However, that never have worked on my Yatse app, which runs on two Android phones.

To reconnect, I need to search for Kodi’s host again, which works, and the Host is found.

I’d like to ask to add a feature that simply runs that search & update host IP automatically when Yatse is launched.

Thanks for great app!

As you have said, it’s already the case …

Please provide logs How to get debug information and open a proper issue and more details.

debug-20210621_223346.zip (15.5 KB)

The bug is reproduced, and logs are attached.
I started yatse which had host defined on 192.168.1.8.
But since the host IP changed to 192.168.1.115, I had to manually update it in yatse.

And the next day it happened again:
Yatse had 192.168.1.15 set for the kodi host (from yesterday), but it wasn’t connected, since today the IP was changed back to 192.168.1.8 apparently.

I had to manualy scan in yatse, which worked, and then I set that new IP for the same host.

Attaching log.
debug-20210622_064706.zip (21.5 KB)

Hum from the logs Yatse correctly find the host but can’t match it with previous one so skip the IP update.

It seems the host was first auto detected via Zeroconf but that now either it returns different data from Kodi or zeroconf no more works and it’s found by scan but Kodi returns different data.

Will try to add more logs to better understand the case you are in.

But easiest fix is to remove the host completely from Yatse and add it again to start fresh in the new configuration you are now.

Here’s another log from today:

Yatse: 10.9.0-71108194 [true/0/68/126]
Android: 8.0.0 - 26 [arm64-v8a,armeabi-v7a,armeabi]
Device: samsung - SM-G930U [heroqlteue - heroqlteue]

debug-20210627_084622.zip (10.5 KB)

Another point to mention that I have 2 android devices with the Yatse app, to control the kodi’s host.
Could two Yatse clients make a conflict for each other if having same host IP ?

No Yatse does not interfere with itself.

Have you fully removed the host as requested to start fresh?

The logs are the same, the host is found but Yatse can’t match it with the previous one. I’ll try to build a beta APK with the added logs to see why.

Here’s a test APK with more logs and a workaround for when zeroconf answer too late.

Yatse-beta-arm64-v8a-final.apk (8.7 MB)

I did not remove the host yet, although I’m quite sure I did remove it few times in the past, but this problem was always there, not something new (I just never reported it here).

I will try to use this APK, and will update how it works. Thank you!

Hi again,
After I’ve installed this apk, it was still not connecting at first time:
debug-20210628_204703.zip (55.1 KB)

However, once I deleted the host, and re-added it, it worked great, and the new host IP was detected (tested for week+ already):

debug-20210701_065111.zip (6.2 KB)

Logs attached.

Well logs don’t show what was the error before :frowning:

But glad that the removal did fix the issue as expected.