Adding Emby Device/Server with reverse proxy

I read in Version 7.6.5 it had support for reverse proxy but i tried and I’m clueless how to add it, it always gives me errors, and there is nothing on the wiki about this.

Any help will be appreciated. Especially because I bought the play store version (I had the amazon one) to have the latest version.

Best Regards,
Marc M. S.

Without that error code and any information about your setup and what you try to do it’s quite hard to answer :slight_smile:

Please take time to gather logs and give more details :slight_smile:

Well I didn’t provide errors because to begin with I didn’t know how to add a server with reverse proxy to yatse, and I assumed most of the errors were because I was doing it wrong. I wanted to know how to add it.

The error (it’s translated to english from my original error in spanish , the original english error might be different):

“The server version couldn’t be obtained. Check the port number and check that it isn’t used for any other program. Use ·“Help” to check how to configure the server”

The log is attached , this is from attempting to add the server attaching the subpath ("/emby") at the end of the “ip”.
Beware that I replaced the references to my domain in the log, for aaaaa.bbbbb.stream instead of the real one.

debug.log (4.6 KB)

Ok so the issue is not about reverse proxy it’s about adding a subpath :slight_smile:

You can’t add path in a hostname as it’s not part of an host name.

This is not supported from the wizard as 99,99999% would not understand, you need to add the host with your local IP, then edit the host and fill the fields with the new values.

Yeah well i added it to the hostname cause there wasnt any other place to place it.

It would be nice if it was in the wizard as an advanced option or some expert mode.

Cause now I have to open the port to directly connect, after that I can edit the host to add the subpath.

Thanks for helping out, now works fine.

Logic way is to add your host with you lan IP first :slight_smile: Then configure for external if you use subpath.

I won’t add complexity to the wizard for 0,000001% of users when there’s workaround that users able to to use reverse proxy with subpath should be able to handle easily :slight_smile:

Yeah but the thing is that the emby server isn’t in my local network, that’s why I had to open the port, well either that or a vpn or similar.