Add Subtitles support with Plex media files


#1

Add Subtitles support for Plex

Well the title defines exactly what i request you to add in futute updates I use my Plex media server with your licensed-App But i face issues as my local subtitles are not detected and it's hard to find online subtitles with MX player or VLC. Thanks

#2

As answered on Twitter subtitles are supported.

So what it precisely the issue with logs https://yatse.tv/wiki/debug-yatse-kodi-remote


#3

Attached logs
I don’t see any subtitles dude!

debug-20180821_000458.zip (9.4 KB)


#4


#5

I see other things :wink:

I see
2018-08-21 00:04:17.961 Verbose/PlexDataProvider: [email protected]: Subtitle found: https://192.168.178.30:32400/library/streams/259/English
2018-08-21 00:04:17.962 Verbose/PlexDataProvider: [email protected]: Subtitle found: https://192.168.178.30:32400/library/streams/258/हिन्दी, हिंदी
2018-08-21 00:04:17.962 Verbose/MediaHelper: [email protected]: External subtitles founds: 2

And

Starting external video player with intent: Intent { act=android.intent.action.VIEW dat=https://192.168.178.30:32400/… typ=video/* flg=0x1 (has extras) } - Bundle[{video_list=[Landroid.net.Uri;@780acfb, video_list_is_explicit=true, subs=[Landroid.net.Uri;@ba05118, title=The Great Game, position=1, secure_uri=true, return_result=true}]

Meaning subs are found and correctly set for Mx Player.
If you want a sub to work for VLC you need to select the correct video player in settings.

So from Yatse point of view all is OK Dude! :wink:

One guess could be that MxPlayer does not support the non ascii characters in the Url.
Can you send me the hindi subtitle for that file so I can try to reproduce?


#6

Sir
first of all i don’t use hindi subtitles!
Second of all I tried changing my default video player from VLC to MX but still no success
can’t see any subs showing up in either of these two players (VLC AND MX)


#7

Plex

Yatse


#8

Dear user,

First of all, this file have Hindi subtitles! Since Plex says that there is Hindi subtitles.
{“id”:258,“key”:"/library/streams/258",“streamType”:3,“codec”:“srt”,“language”:“हिन्दी, हिंदी”,“languageCode”:“hin”,“displayTitle”:“हिन्दी, हिंदी (SRT)”}

Second to change the player you need to select it in Yatse settings as told (General settings).

So please either provide those subs, or try with a file that does not have hindi subs and confirm it works (or provide new logs).


#9

So let’s just get it fixed for once and for all

Now I’ll be attaching everything you’ll need
Note: This time each and every(if more than one) subtitle was in English Language

Here are the fresh logs :slight_smile:
debug-20180821_221312.zip (7.8 KB)

And here the the LOCAL subtitles from my directory :slight_smile: :
Oh wait i can’t upload it here
I’ll leave a link thn i guess
https://drive.google.com/file/d/1MQ_dogpCvtX5_JGe_fznNnbt7jNfxRw6/view?usp=drivesdk
:slight_smile:

I’m right here if u need anything :grinning:

Additional :


#10

No need to show me the log you send :slight_smile:

Anyway trying every possible way and subtitles always do always work.

Do you click the subtitle button after in Mx Player to select the subtitle? (When no hindi as that maybe an issue but you have not sent any :slight_smile: )


#11

Or maybe you are using a beta or modified MxPlayer?


#12

Subtitle button doesn’t appear when it detects no subtitles
But when I play the same video in plex app i do see subtitles
(I just don’t like plex app and i prefer yastse, being a long time Kodi user i just love it UI now)

and I’m using ORIGINAL and Updayed Mx player from PlayStore


#13

Leave hindi Subtitles
i don’t use it
I accidentally turned it on in plex server configuration

I have now turned it off!
Now there’s only English subs


#14

and By the way :smile:

Unknown sub = Local subs
English = Online subs from Opensubtitles(.)org


#15

Well logs shows that everything is correct at all levels.

Only possible issue is now at Mx Player level do you have access to logcat?

But I doubt I can fix Mx Player issues :wink: