Now Playing disappears after returning to Yatse after having the phone locked (android 11)

Using Android 11 on the new Pixel 4a ‘Now playing’ disappears when returning to Yatse after having the phone locked. Repeating the process causes it to alternate between appearing and disappearing. Switching to another app and back will bring Now playing back.
debug.log (93.1 KB)

I can reproduce fun to see the number of broken things in that release, don’t understand the need of timed release for OS versions specially after the Covid delays …

Anyway the screenshots are missing the navigation bar are you using some special settings / tools ?

On android 11 you don’t press power button and volume for screenshot, you swipe up and then press screenshot. This is the output. I thought it was a bit odd too.

Oh ok :slight_smile:
Previous way still works and still capture the nav bar, may be better for reports to devs so they know your navigation settings.

Same problem for me on a pixel 2xl. It worked fine until I took the android 11 update last week. Now it frequently loses the “now playing” banner and controls after locking phone or switching apps.

I just tried turning battery optimizations off for yatse, not sure if it helped though.

Next version currently in beta have a “fix” for that.

Thanks a lot. Works.