Keyboard Issues

I run Kodi under OSMC on a Raspberry Pi. For some reason, the keyboard function (just entering text) does not work. The logitech keyboard works fine as do other remotes. But I cannot seem to get Yatse to enter text? Ideas?

The specific issue is on one addon, I can use my harnomy remote or keyboard to enter a channel number and it goes to that channel. When I bring up the yatse keyboard, that does not happen.


Without logs and more details it’s nearly impossible to tell anything :slight_smile:

But if it’s a false dialog and you want to emulate a real keyboard, you need to long press the keyboard button in the left menu.

Thanks! Tried the “long press” and that does not work.

But I created “custom” command for “keyboard key” for numbers 0-9 and that works.

But I cannot seem to do the same for enter (or return) and backspace.

Not the best solution but usable (if I can get enter or return) to work.

Not much I can do it’s addon strange stuff.

But can’t you just use the remote keys to click on that dialog? Remote screen is always available when swiping from right of screen.

Yes, You are right, it is a funky add on issue. I can now enter numbers using the custom remote commands I added and “normal” return works fine. So I am sorted. Thanks!!