After update the setting for "internal shortcuts" gets reverted to OFF

Issue description:
I like to set Settings -> Interface -> Advanced -> internal shortcuts -> ON
Unfortunately, after each update this setting gets reverted to OFF (default).
This happened for at least last 2 updates.

I always update yatse via play store. Current version 9.5.5.a.

My phone is Samsung Galaxy Note 9, official Android 10. I’m not sure if this is relevant, but this issue was happening also before update to Android 10.

Logs:
debug-20200127_223828.zip (2.0 KB)

Some users have a problem with Google sending wrong data and Yatse not ignoring it :frowning:
Leading to temporary license removal and reset of paid settings.

I’ve added some possible workaround + more logs for next version but since for the moment no one have been able to provide logs of the update it’s not 100% sure.

What would be nice is if you can disable automatic updates for Yatse then before updating to next version enable logs so I can see the real issue if it happens again.

OK, I already have auto-updated disabled.
Will do as you requested,
p

Hi,

I noticed that new version was released.
However before I did anything I also noticed that Internal Shortcuts are OFF again.
It seems that this issue is not related to update process at all. Previously it was just a coincidence.

Therefore I just did the following (without updating):

  1. enable debug
  2. switch Internal Shortcuts ON
  3. disable debug

logs attached,
P

debug-20200202_214327.zip (4.1 KB)

I need logs activated during the reproduction of the issue :frowning:

Hi,
after several days and few updates I no longer can reproduce the problem.
We can assume that it’s gone.
Please close case.
thank you!
P